Mails not sent from Reports

I'm trying to test-send a mail with a report. In e-mail config, the testmail is sent as it should, if I preview the report it works just fine, but I cannot send the report by mail (not manually or scheduled). I get no error messages in the log, so not much help there. Please advise. :)





 

[�[32m2019-03-29T09:56:48.084�[39m] [�[32mINFO�[39m] [�[32mreports_3.12.1_chromium�[39m] - User click - Initiating mail now/generate now

[�[32m2019-03-29T09:56:48.088�[39m] [�[32mINFO�[39m] [�[32mreports_3.12.1_chromium�[39m] - SettingsDAO - Obtained timezone settings successfully 

[�[36m2019-03-29T09:56:48.088�[39m] [�[36mDEBUG�[39m] [�[36mreports_3.12.1_chromium�[39m] - SettingsDAO - Timezone saved  Europe/Stockholm

[�[32m2019-03-29T09:56:48.135�[39m] [�[32mINFO�[39m] [�[32mreports_3.12.1_chromium�[39m] - SettingsDAO - other settings data  { zoomfactor: 68,
  basefolder: '/home/adaadmin/skedler/reports/reports/' }

[�[32m2019-03-29T09:56:48.136�[39m] [�[32mINFO�[39m] [�[32mreports_3.12.1_chromium�[39m] - SettingsDAO - No custom param available 

[�[32m2019-03-29T09:56:48.145�[39m] [�[32mINFO�[39m] [�[32mreports_3.12.1_chromium�[39m] - SettingsDAO - Obtained email settings successfully 

[�[36m2019-03-29T09:56:48.145�[39m] [�[36mDEBUG�[39m] [�[36mreports_3.12.1_chromium�[39m] - SettingsDAO - Email details  { emailconfig: 
   [ { service: 'SES-others',
       host: 'xxxx.xxxx.xx',
       port: 25,
       ssl: false,
       from: 'xxx@xxx.xx',
       username: 'xxxx',
       adminMail: 'xxxxx@xxxx.xx',
       password: 'xxxxxxxxxxxxxxxxxxxxxxxxxxxxx',
       authentication: true } ],
  emailenable: true }

[�[32m2019-03-29T09:56:48.146�[39m] [�[32mINFO�[39m] [�[32mreports_3.12.1_chromium�[39m] - SettingsDAO - Obtained timezone settings successfully 

[�[36m2019-03-29T09:56:48.146�[39m] [�[36mDEBUG�[39m] [�[36mreports_3.12.1_chromium�[39m] - SettingsDAO - Timezone saved  Europe/Stockholm

[�[32m2019-03-29T09:56:48.147�[39m] [�[32mINFO�[39m] [�[32mreports_3.12.1_chromium�[39m] - SettingsDAO - Obtained slack settings successfully 

[�[36m2019-03-29T09:56:48.147�[39m] [�[36mDEBUG�[39m] [�[36mreports_3.12.1_chromium�[39m] - SettingsDAO - Slack details  { slackconfig: [], slackenable: false }

[�[32m2019-03-29T09:56:48.148�[39m] [�[32mINFO�[39m] [�[32mreports_3.12.1_chromium�[39m] - DashboardDAO -  Use dashboard time checked

[�[32m2019-03-29T09:56:48.148�[39m] [�[32mINFO�[39m] [�[32mreports_3.12.1_chromium�[39m] - Report generation for Time window

[�[32m2019-03-29T09:56:48.149�[39m] [�[32mINFO�[39m] [�[32mreports_3.12.1_chromium�[39m] - Timewindow quick

[�[32m2019-03-29T09:56:48.149�[39m] [�[32mINFO�[39m] [�[32mreports_3.12.1_chromium�[39m] - DashboardHelper - Condition for quick  now-15mnow

[�[32m2019-03-29T09:56:48.149�[39m] [�[32mINFO�[39m] [�[32mreports_3.12.1_chromium�[39m] - DashboardHelper - From and To timestamp in get intervel method 2019-03-29T08:41:48Z 2019-03-29T08:56:48Z

[�[32m2019-03-29T09:56:48.151�[39m] [�[32mINFO�[39m] [�[32mreports_3.12.1_chromium�[39m] - SearchDAO - Retrieved data index { type: 'dashboard',
  updated_at: '2019-03-25T14:23:23.248Z',
  dashboard: 
   { title: 'Hultsfred Start',
     hits: 0,
     description: '',
     panelsJSON: '[{"embeddableConfig":{},"gridData":{"x":0,"y":0,"w":12,"h":7,"i":"1"},"id":"8887cd50-0f37-11e9-a4cb-c9cc38bb46cf","panelIndex":"1","type":"visualization","version":"6.4.2"},{"embeddableConfig":{"vis":{"legendOpen":true}},"gridData":{"x":0,"y":7,"w":12,"h":18,"i":"2"},"id":"21c66890-1006-11e9-a4cb-c9cc38bb46cf","panelIndex":"2","type":"visualization","version":"6.4.2"},{"gridData":{"x":36,"y":0,"w":12,"h":33,"i":"4"},"version":"6.4.2","panelIndex":"4","type":"visualization","id":"3d2c7a90-0e92-11e9-a4cb-c9cc38bb46cf","embeddableConfig":{"mapZoom":5,"mapCenter":[63.174193604205094,17.644042968750004]}},{"gridData":{"x":12,"y":15,"w":12,"h":10,"i":"5"},"version":"6.4.2","panelIndex":"5","type":"visualization","id":"db6cf5e0-4f06-11e9-afe5-e36c5c15368f","embeddableConfig":{"vis":{"legendOpen":false}}},{"gridData":{"x":24,"y":15,"w":12,"h":10,"i":"6"},"version":"6.4.2","panelIndex":"6","type":"visualization","id":"05cc0460-4f08-11e9-afe5-e36c5c15368f","embeddableConfig":{"vis":{"legendOpen":false}}},{"gridData":{"x":12,"y":0,"w":24,"h":15,"i":"7"},"version":"6.4.2","panelIndex":"7","type":"visualization","id":"27dd3820-4f09-11e9-afe5-e36c5c15368f","embeddableConfig":{"vis":{"legendOpen":false}}}]',
     optionsJSON: '{"darkTheme":false,"hidePanelTitles":false,"useMargins":true}',
     version: 1,
     timeRestore: false,
     kibanaSavedObjectMeta: 
      { searchSourceJSON: '{"query":{"language":"lucene","query":""},"filter":[]}' } } }

[�[32m2019-03-29T09:56:48.153�[39m] [�[32mINFO�[39m] [�[32mreports_3.12.1_chromium�[39m] - ReportHelper - Preview Mail now enabled

[�[32m2019-03-29T09:56:48.154�[39m] [�[32mINFO�[39m] [�[32mreports_3.12.1_chromium�[39m] - Request for report generation sent to  http://elasticada:666/generatereport

[�[32m2019-03-29T09:56:48.159�[39m] [�[32mINFO�[39m] [�[32mreports_3.12.1_chromium�[39m] - undefined


 

1 Comment

Hi Emil Brolin,


Thanks for contacting Skedler.


Can you kindly check your machine hostname details as given below. 


Follow the steps to check for hostname configuration,


1. Configure the hostname as below:

  • Check your hostname by giving this command 

              $> hostname


2. In Skedler configuration file $skedler_home/reporting.yml the host parameter is the host in which Skedler binds.


  • If the host is configured as 127.0.0.1 then make sure you have an entry in /etc/hosts as mentioned below

              127.0.0.1 localhost

Note: if you are binding Skedler to localhost you can't access it from outside.

  • If  the host in reporting.yml is configured as 0.0.0.0(bind to any ip) or  your server's ip then the entry in hosts file (/etc/hosts) should be,

              <ipaddress> <hostname>


3. Reboot the machine


NOTE:  If you are using any proxy server add your hostname to a no_proxy list in the file /etc/environment add the following line,

no_proxy="<ipaddress>,<hostname>"


Login or Signup to post a comment